ceres-ui module is needed by some operations in snappy

Description

When using certain operations from python the following error can happen:

RuntimeError: org.esa.snap.core.gpf.OperatorException: com/bc/ceres/swing/figure/FigureStyle

The ceres-ui module is necessary but is currently excluded. ceres-ui is a dependency of snap-gpf.

From the forum:
https://forum.step.esa.int/t/using-mask-file-with-kmeansclusteranalysis-in-python/2423/5
https://forum.step.esa.int/t/error-in-snap/10151/5

Environment

None

Assignee

Marco Peters

Reporter

Marco Peters

Labels

None

Components

Fix versions

Affects versions

Priority

Major
Configure